Arduino Software Quickstart for RobotGeek

This guide will show you how to install the Arduino IDE (Integrated Developer Environment) on your computer and then use the Arduino IDE to program your Geekduino board. The RobotGeek Geekduino is an Arduino-Compatible micrcocontroller that is compatible with the Arduino IDE and any standard Arduino code. This is the standard board for all RobotGeek kits. Completing this guide is critical to being successful with your RobotGeek kit.

This is the quick start guide for the RobotGeek Geekduino. This guide will use the Arduino Boards Manager to quickly install and update all the files you need for the RobotGeek Kits. The Arduino Boards Manager will handle installation and updated for you. However if you are planning on using a non-Geekduino board (i.e. Arduino Uno) or you plan on developing/modifying libraries, we highly recommend that you go to the full Geekduino Getting Started Guide

Contents:

Step 1: Setting up the Arduino Software

Click on your operating system to expand instructions to guide you through the getting started process.

ico-windows.png Click here to expand Windows Instruction

ico-apple.png Click here to expand Apple Instruction

ico-linux.png Click here to expand Linux Instruction

Back to Contents

Step 2: Installing the FTDI drivers

Click on your operating system to expand instructions to guide you through the getting started process.

ico-windows.png Click here to expand Windows Instruction

ico-apple.png Click here to expand Apple Instruction

ico-linux.png Click here to expand Linux Instruction

Back to Contents

Step 3: Setting up the RobotGeek Tools and Libraries

In this guide we're going to set up the RobotGeek Tools and Libraries using the Arduino Boards Manager. The Boards Manager will install all the files for the RobotGeek Geekduino as well as various libraries used by the RobotGeek system. This method is very easy to setup and makes updating your libraries very easy.

First, open your Arduino Preferences, File -> Preferences. In the box labeled Additional Boards Manager URLs:, copy the following URL

http://learn.robotgeek.com/package_robotgeek.com_geekduino_index.json

If your Additional Boards Manager URLs: is not blank, click on the button to the right of the field. This will allow you to enter the URL on a sperate line from any other board manager URLs.

Click 'OK' to save and exit the preferences

Now navigate to

Tools -> Board -> Boards Manager

Once the Boards Manager is open, type RobotGeek into the search bar. You should now see RobotGeek AVR Boards in the Boards Manager.

Click on the RobotGeek AVR Boards entry to highlight it. You should now see a button that says 'Install' - click on it to Install the files.

Now select the Geekduino.

Tools -> Board -> RobotGeek Geekduino

You must select the Geekduino board to continue - if you do not select the Geekduino, the examples / libraries will not show up.

To check if library installation was successful, navigate to

File -> Examples -> RobotGeekSketches -> Tests -> libraryTest

If you do not see RobotGeekSketches under Examples then you have not installed the files correctly.

Once you have the libraryTest sketch open, click on the 'Verify' Button (the green check in the upper left). This will attempt to compile the sketch. If all of the software is installed properly you will see a 'Done Compiling' below the editor. If you get any errors, the library files have not been placed properly.

If you are planning on using a non-Geekduino board (i.e. Arduino Uno) or you plan on developing/modifying libraries, we highly recommend that you go to the full Geekduino Getting Started Guide to install the tools and libraries. If you have already installed the files via the board manager, you can also remove them from the boards manager.

Back to Contents

Step 4: Programming Your Board

If you have not already done so, connect your Geekduino to your computer using a USB Micro Cable. This is also a good time to make sure the Geekduino's switches are set correctly. The VCC Switch should be set to 5v and the Reset Switch should be set to AUTO. geekduinoMount0.jpg

If your board is getting power from the USB connection properly, the green power LED (next to the reset switch labeled PWR) will turn on.

Now that your Geekduino is hooked up to your computer, you will need to pick the correct board from the boards menu. Select the proper board by going to:

Tools -> Board -> RobotGeek Geekduino
b_500_500_16777215_00__images_tutorials_geekduino_board-1.png

Now you will need to select the proper processor. The Geekduino uses an ATmega328 chip. Select it by going to:

Now pick the correct serial port. Go to:

 Tools -> Port

and pick the serial port for the Geekduino

b_500_500_16777215_00__images_tutorials_geekduino_board-3.png
  • On Windows, the serial port will be the text COM followed by a number, like COM3
  • On Mac, the serial port will be the text /dev/cu.usbserial followed by a random number, like /dev/cu.usbserial-AL4223
  • If you have multiple serial ports and you are not sure which one is the Geekduino, unplug the FTDI device from the computer, then re-open the Serial Port menu. The serial port that has disappeared is the serial port with the Geekduino attached.
  • Mac and Linux users may have 2 ports - one marked 'cu.' and one marked 'tty.' Either will work.

Once you have the board and serial port set, you can open the 'Blink' Sketch

File -> Examples -> 01.Basics ->Blink 

Click on the 'Verify' Button (the green check in the upper left). If all of the software is installed properly you will see a 'Done Compiling' below the editor.

Now click on the 'Upload' button (the green arrow button next to the verify button). This will compile the sketch, and then load it onto the Geekduino. If the hardware is connected properly you will see the red TX/RX LEDs flicker on the Geekduino while the Arduino IDE displays an 'Uploading' message. When the Arduino IDE displays 'Done Uploading' the green user LED should blink on and off in a 1 second interval.

If you see any red text or error messages, then the sketch has not been loaded properly. Make sure you have installed the FTDI drivers, chosen the correct board and serial port, and that your USB connection is secure.

Step 5: Setting Your Preferences

Arduino has many features and preferences to customize your experience. Before you get started, let's set a couple of the basic preference . Open up your preferences menu:

File -> Preferences

Mac users will find their preferences under Arduino -> Preferences

b_500_500_16777215_00__images_tutorials_geekduino_board-5.png

Now take a look at the settings tab:

Preferences -> Settings

There is a column of checkboxes. We recommend checking "Display line numbers" for easy debugging.

b_500_500_16777215_00__images_tutorials_geekduino_board-6.png

There is also a default setting, "Save when verifying or uploading". We recommend that you keep this checked. This will save your sketch automatically when you click on the Verify Button or the Upload Button .

b_500_500_16777215_00__images_tutorials_geekduino_board-7.png

Congratulations, you just programmed your Geekduino! Go back to the Getting Started Guide for your kit to proceed.

Back to Contents

Feedback Form


Search