Geekduino Getting Started Guide / Arduino IDE 1.6.X Setup

This guide will refer to the RobotGeek Geekduino, the microcontroller that will ship with RobotGeek Robot Kits. If you are using one of our kits with another Arduino-Compatible controller, like the Arduino Uno, Seeeduino, etc, follow the setup guide from that particular manufacturer. You can then skip steps 1 and 2 on this guide, and go straight to Setting up the RobotGeek Tools and Libraries

This guide will show you how to install the Arduino IDE (Integrated Developer Environment) on your computer and then use the Arduino IDE to program your Geekduino or Arduino board. The RobotGeek Geekduino is an Arduino-Compatible micrcocontroller that is compatible with the Arduino IDE and any standard Arduino code. Completing this guide is critical to being successful with your RobotGeek kit.

This guide covers Arduino IDE version 1.6.X+. If you are looking for a guide covering the older version 1.0.6 Arduino IDE, you can find it here.

Contents:

Step 1: Setting up the Arduino Software

Click on your operating system to expand instructions to guide you through the getting started process.

ico-windows.png Click here to expand Windows Instruction

ico-apple.png Click here to expand Mac OS X Instruction

ico-linux.png Click here to expand Linux Instruction

Back to Contents

Step 2: Installing the FTDI drivers

Click on your operating system to expand instructions to guide you through the getting started process.

ico-windows.png Click here to expand Windows Instruction

ico-apple.png Click here to expand Mac OS X Instruction

ico-linux.png Click here to expand Linux Instruction

Back to Contents

Step 3: Setting up the RobotGeek Tools and Libraries

Click on your operating system to expand instructions to guide you through the getting started process.

ico-windows.png Click here to expand Windows Instruction

ico-apple.png Click here to expand Mac OS X Instruction

ico-linux.png Click here to expand Linux Instruction

Back to Contents

Step 4: Programming Your Board

If you have not already done so, connect your Geekduino to your computer using a USB Micro Cable. This is also a good time to make sure the Geekduino's switches are set correctly. The VCC Switch should be set to 5v and the Reset Switch should be set to AUTO. geekduinoMount0.jpg

If your board is getting power from the USB connection properly, the green power LED (next to the reset switch labeled PWR) will turn on.

Now that your Geekduino is hooked up to your computer, you will need to pick the correct board from the boards menu. Select the proper board by going to:

Tools -> Board -> Arduino Duemilanove or Diecimila
b_500_500_16777215_00__images_tutorials_geekduino_board-1.png

Now you will need to select the proper processor. The Geekduino uses an ATmega328 chip. Select it by going to:

Tools -> Processor -> ATmega328
b_500_500_16777215_00__images_tutorials_geekduino_board-2.png

Now pick the correct serial port. Go to:

 Tools -> Port

and pick the serial port for the Geekduino

b_500_500_16777215_00__images_tutorials_geekduino_board-3.png
  • On Windows, the serial port will be the text COM followed by a number, like COM3
  • On Mac, the serial port will be the text /dev/cu.usbserial followed by a random number, like /dev/cu.usbserial-AL4223
  • If you have multiple serial ports and you are not sure which one is the Geekduino, unplug the FTDI device from the computer, then re-open the Serial Port menu. The serial port that has disappeared is the serial port with the Geekduino attached.
  • Mac and Linux users may have 2 ports - one marked 'cu.' and one marked 'tty.' Either will work.

Once you have the board and serial port set, you can open the 'Blink' Sketch

File -> Examples -> 01.Basics ->Blink 

Click on the 'Verify' Button (the green check in the upper left). If all of the software is installed properly you will see a 'Done Compiling' below the editor.

Now click on the 'Upload' button (the green arrow button next to the verify button). This will compile the sketch, and then load it onto the Geekduino. If the hardware is connected properly you will see the red TX/RX LEDs flicker on the Geekduino while the Arduino IDE displays an 'Uploading' message. When the Arduino IDE displays 'Done Uploading' the green user LED should blink on and off in a 1 second interval.

If you see any red text or error messages, then the sketch has not been loaded properly. Make sure you have installed the FTDI drivers, chosen the correct board and serial port, and that your USB connection is secure.

Step 5: Setting Your Preferences

Arduino has many features and preferences to customize your experience. Before you get started, let's set a couple of the basic preference . Open up your preferences menu:

File -> Preferences

Mac users will find their preferences under Arduino -> Preferences

b_500_500_16777215_00__images_tutorials_geekduino_board-5.png

Now take a look at the settings tab:

Preferences -> Settings

There is a column of checkboxes. We recommend checking "Display line numbers" for easy debugging.

b_500_500_16777215_00__images_tutorials_geekduino_board-6.png

There is also a default setting, "Save when verifying or uploading". We recommend that you keep this checked. This will save your sketch automatically when you click on the Verify Button or the Upload Button .

b_500_500_16777215_00__images_tutorials_geekduino_board-7.png

Congratulations, you just programmed your Geekduino! Go back to the Getting Started Guide for your kit to proceed.

Back to Contents

Feedback Form


Search